'
1
Forums Albums Skins 1
Search Register Logon


You are logged in as a guest. Logon or register an account to access more features.
OTHER FORUMS:    Barrel Horses  -   Trucks   -   Cutting  -   Reining  -   Roping 
'
Water heater not working on LP

Jump to page : 1
Now viewing page 1 [25 messages per page]
Last activity 2021-06-12 10:32 PM
5 replies, 192 views

View previous thread :: View next thread
   General Discussion -> Trailer Talk  Click to return to Barrel Talk
Refresh
Message format
 
BJMCFW
Reg. Jan 2021
Posted 2021-06-10 8:03 PM (#173751)
Subject: Water heater not working on LP


Regular


Posts: 50
2525
Here we are again. Only had this trailer 3 months and not only we still can not get the tags for it the water heater isn't working again.
First weekend we brought it home we was checking everything just to make sure. (Dealers words was "everything is just like new and ready to go" cause we go thru these top to bottom front to rear) Hog wash.
Water heater would only get warm using electric would never light on propane. Hauled it back to get fixed with list of other items. Service guy said some switch under the tanks was bad he replaced the switch and seemed to work at the dealership. 3 months later we are ready to actually use it and water heater started right up on propane for about 5 mins the shut off. Check the bottles and the are almost full check the stove top and it started right up, check the refrigerator and it runs on LP with no problems! Water heater will get warm using electric but never gets hot!

WHAT am I missing????

Not to mention in the mean time with all of the rain we had we find out the skylight over the shower was cracked and leaking water everywhere and looks like someone use duct tape trying to cover the cracks.
Oh yeah the dealer really checked this out top to bottom front to rear!

Beyond MAD!
share Top of the page Bottom of the page
RustyScupper
Reg. Mar 2013
Posted 2021-06-11 12:46 PM (#173752 - in reply to #173751)
Subject: RE: Water heater not working on LP


Veteran


Posts: 104
100
Location: Wi
Because you said that the refrigerator works I am making the assumption that you have a charged battery to run the ignitor on the water heater.  Also, that you had the stove working any air in the lines was purged. I assume that you have the water pump on or are running city water.

The only thing I can think of beyond a electrical component failure is that there is a valve that is in the wrong positon.  There are safety features that will not allow the water to heat if the water heater isnt full of water.  (been there in the spring after unwinterizing)

When you turn the hot water on at a faucet do you get a steady stream of water or a lot of air?

Another way to check is to make sure the water is cooled off (doesnt sound like that is a problem).  Pull the drain plug out of the water heater and try and collect the water in a 5 gal bucket.  Is it pretty full or minimal amount.  This is where I am leaning since the dealer supposedly fixed it.  The electric element would probably get hotter quicker than the gas before it shut down.
share Top of the page Bottom of the page
akinstrailers
Reg. Apr 2009
Posted 2021-06-11 2:09 PM (#173753 - in reply to #173751)
Subject: RE: Water heater not working on LP


Veteran


Posts: 139
10025
Location: Harrisburg, OR
Sounds like you could be mixing hot and cold water.  Have you checked the inline bypass valves to make sure they're in the correct position?  Also, make sure the correct valves are actually opened or closed.  We've found sometimes customers pull the knob off and put it back on in the wrong position...
share Top of the page Bottom of the page
BJMCFW
Reg. Jan 2021
Posted 2021-06-11 5:01 PM (#173754 - in reply to #173751)
Subject: RE: Water heater not working on LP


Regular


Posts: 50
2525
Igniter is working because it lite on the first try run on lp 3 to 5 mins the shut off. Plenty of LP, hooked to city water and purge the air before I even messed with the water heater. When I turned on the electric part of the heater the hot water would get warm and the cold water was cold!

Guessing maybe a bad water heater?

share Top of the page Bottom of the page
RTSmith
Reg. Nov 2003
Posted 2021-06-12 6:39 AM (#173756 - in reply to #173751)
Subject: RE: Water heater not working on LP


Elite Veteran


Posts: 707
500100100
Location: Tenn/Ala.
For the most part, the two parts of the water heater work completely separate from each other, only sharing the tank. So whatever issues you are having with the LP functions, have no impact on the electric. So diagnose each on their own.

There is a thermostat type device to tell the heater when to turn on/off. On the LP side, these don't give a lot of issues, but can. Memory serves the gas temp is 145 degrees shutoff. So the tank will definitely feel warm from the outside access. You just need to figure out if it is getting to temp. But- we generally expect a 12-15 minute run time to get from room temp to shutoff temp. So if you are shutting off at 6 minutes, you probably aren't hot yet and need to figure out why it thinks it is needing to shut down. If it is hot, then you need to figure out flow pattern like Akin pointed out. 

 
share Top of the page Bottom of the page
BJMCFW
Reg. Jan 2021
Posted 2021-06-12 10:32 PM (#173759 - in reply to #173751)
Subject: RE: Water heater not working on LP


Regular


Posts: 50
2525
So I'm still lost! All of the other trailers we have owned when I turn the water heater ON using LP the burner runs as long as the switch is ON! This one started 1 time and the burner run a few minutes then shut off as if I turned the switch off and will not fire back up. I hear the igniter clicking but nothing else!
Still not understanding when using the electric side the water temp only gets warm at most!
share Top of the page Bottom of the page
Jump to page : 1
Now viewing page 1 [25 messages per page]
Jump to forum :
Search this forum
Printer friendly version
E-mail a link to this thread
Message format
 

'
Registered to: Horse Trailer World
(Delete all cookies set by this site)